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1. System configuration 

The system configuration of TOP and “S & E TMS Series” is as follows. 

 

Series 
Communication 

method 
System setting Cable 

TMS-080 

TMS-160 

TMS-160W 
 

Ethernet (TCP) 3. TOP communication setting Twisted pair cable*Note 1) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connection configuration 

ㆍ1:1 connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “S & E”. 

Model 

Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

TMS-080, TMS-160, TMS-160W Ethernet Private Protocol 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [HMI settings > Check “Use HMI settings” > Edit > Ethernet ] 

- Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.1  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > Device setting > Ethernet > “PLC1 : TMS-080” ] 

– Set the options of the communication driver of TMS Series Ethernet in TOP Design Studio. 

 

* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Private Protocol”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an 

external device and sending the next command request.  
Not used 

 

● Spot Info 

Count  The number of spots of the corresponding thermal imaging camera.  

X Pos Start Address Set the start address of the X coordinate.  

Y Pos Start Address Set the start address of the Y coordinate.  

Max Temperature Start Address Set the start address of the maximum temperature value. *Note 1) 
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● Area Info 

Count  The number of areas of the corresponding thermal imaging camera.  

Use Start Address Set the start address of the Enabled/Disabled value. Enabled: 1, Disabled: 0 

TopLeft X Pos Start Address Set the start address of the upper left X coordinate.  

TopLeft Y Pos Start Address Set the start address of the upper left Y coordinate.  

BottomRight X Pos Start Address Set the start address of the lower right X coordinate.  

BottomRight Y Pos Start Address Set the start address of the lower right Y coordinate.  

Max Temperature Start Address Set the start address of the maximum temperature value. *Note 1) 

Alarm State Start Address Set the start address of the alarm status value. Occurrence: 1, Non-

occurrence: 0 

Warning1 State Start Address Set the start address of the warning 1 status value. Occurrence: 1,  

Non-occurrence: 0 

Warning2 State Start Address Set the start address of the warning 2 status value. Occurrence: 1, 

 Non-occurrence: 0 

Alarm Temperature Start Address Set the start address of the temperature value where the alarm 

occurs. 
*Note 1) 

Warning1 Temperature Start 

Address 

Set the start address of the temperature value where warning 1 

occurs. 
*Note 1) 

Warning2 Temperature Start 

Address 

Set the start address of the temperature value where warning 2 

occurs. 
*Note 1) 

Target Distance Start Address Set the start address of the subject distance. *Note 1) 

Emissivity Start Address Set the start address of the emissivity.  *Note 2) 

 

● Window Info 

X Pos Address Set the address of X cooridinate.   

Y Pos Address Set the address of Y cooridinate.  

Max Temperature Address Set the address of the maximum temperature value. *Note 1) 

Alarm State Address Set the address of the alarm status value. Occurrence: 1,  

Non-occurrence: 0 

Warning1 State Address Set the address of the warning 1 status value. Occurrence: 1,  

Non-occurrence: 0 

Warning2 State Address Set the address of the warning 2 status value. Occurrence: 1,  

Non-occurrence: 0 

Alarm Temperature Address Set the start address of the temperature value where the alarm occurs. *Note 1) 

Warning1 Temperature Address Set the start address of the temperature value where warning 1 occurs.   *Note 1) 

Warning2 Temperature Address Set the start address of the temperature value where warning 2 occurs.   *Note 1) 

Target Distance Address Set the start address of the subject distance. *Note 1) 

Emissivity Address Set the start address of the emissivity.  *Note 2) 

 

● Camera Info 

Index Address Set the address to display the index of the corresponding index.  

Name Address Set the address to display the name of the corresponding index. 10 words fixed 

ColorMap Set the colormap to use for the thermal image.  

Video Display Type Select the pixel type displayed on the screen.  

Min Set the minimum for absolute value.  

Max Set the maximum for absolute value.  
 

※ Addresses used in the above communication options can be only read. 

*Note 1) The actual value is the value obtained by giving one decimal place to the data value. ex) 1234 -> 123.4 

*Note 2) The actual value is the value obtained by giving two decimal place to the data value. ex) 1234 -> 12.34 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ]  
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.1  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “Private Protocol”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an 

external device and sending the next command request.  
Not used 

 

● Spot Info 

Count  The number of spots of the corresponding thermal imaging camera 

model. 
 

X Pos Start Address Set the start address of the X coordinate.  

Y Pos Start Address Set the start address of the Y coordinate.  

Max Temperature Start Address Set the start address of the maximum temperature value. *Note 1) 
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● Area Info 

Count  The number of areas of the corresponding thermal imaging camera 

model. 
 

Use Start Address Set the start address of the Enabled/Disabled value. Enabled: 1, Disabled: 0 

TopLeft X Pos Start Address Set the start address of the upper left X coordinate.  

TopLeft Y Pos Start Address Set the start address of the upper left Y coordinate.  

BottomRight X Pos Start Address Set the start address of the lower right X coordinate.  

BottomRight Y Pos Start Address Set the start address of the lower right Y coordinate.  

Max Temperature Start Address Set the start address of the maximum temperature value. *Note 1) 

Alarm State Start Address Set the start address of the alarm status value. Occurrence: 1,  

Non-occurrence: 0 

Warning1 State Start Address Set the start address of the warning 1 status value. Occurrence: 1,  

Non-occurrence: 0 

Warning2 State Start Address Set the start address of the warning 2 status value. Occurrence: 1,  

Non-occurrence: 0 

Alarm Temperature Start Address Set the start address of the temperature value where the alarm occurs. *Note 1) 

Warning1 Temperature Start 

Address 

Set the start address of the temperature value where the warning 1 

occurs. 
*Note 1) 

Warning2 Temperature Start 

Address 

Set the start address of the temperature value where the warning 2 

occurs. 
*Note 1) 

Target Distance Start Address Set the start address of the subject distance. *Note 1) 

Emissivity Start Address Set the start address of the emissivity.  *Note 2) 

 

● Window Info 

X Pos Address Set the address of X coordinate.   

Y Pos Address Set the address of Y coordinate.  

Max Temperature Address Set the address of the maximum temperature value. *Note 1) 

Alarm State Address Set the address of the alarm status value. Occurrence: 1, Non-

occurrence: 0 

Warning1 State Address Set the address of the warning 1 status value. Occurrence: 1, Non-

occurrence: 0 

Warning2 State Address Set the address of the warning 2 status value. Occurrence: 1, Non-

occurrence: 0 

Alarm Temperature Address Set the address of the temperature value where the alarm occurs. *Note 1) 

Warning1 Temperature Address Set the address of the temperature value where warning 1 occurs. *Note 1) 

Warning2 Temperature Address Set the address of the temperature value where warning 2 occurs. *Note 1) 

Target Distance Address Set the start address of the subject distance. *Note 1) 

Emissivity Address Set the start address of the emissivity.  *Note 2) 

 

● Camera Info 

Index Address Set the address to display the index of the corresponding index.  

Name Address Set the address to display the name of the corresponding index. 10 words fixed 

ColorMap Set the colormap to use for the thermal image.  

Video Display Type Select the pixel type displayed on the screen.  

Min Set the minimum for absolute value.  

Max Set the maximum for absolute value.  
 

※Addresses used in the above communication options can be only read. 

*Note 1) The actual value is the value obtained by giving one decimal place to the data value. ex) 1234 -> 123.4. 

*Note 2) The actual value is the value obtained by giving two decimal place to the data value. ex) 1234 -> 12.34. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 
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4. External device setting 

 

For external device communication setting, refer to the external device’s manual. 


