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1. System configuration 

The system configuration of TOP and “SEWHA CNM Co., Ltd. – Digital Weighing Indicator SI Series (Command Mode) Computer Link” 

is as follows. 

 

Indicator Model Link I/F 
Communication 

method 
System setting Cable 

SI – 3500 

SI – 4000 

SI – 4010 

SI – 4010R 

SI – 4100 

SI – 4200 

SI – 4300 

SI – 4400 

SI – 4410 

SI – 4420 

SI – 4500 

SI – 4630E 

Serial I/F 

RS–232C 

RS-422 

RS-485 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

 

■ Connection configuration 
 

ㆍ1 : 1 (one TOP and one external device) connection - possible configuration in RS232C communication. 

 

 

 

ㆍ1:N (one TOP and multiple external devices) connection -possible configuration in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Indicator Series”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

SEWHA CNM SI Series Serial Command Mode 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “PLC1 : SEWHA CNM SI Series” ] 

– Set the options of the communication driver of SEWHA CNM Co., Ltd. – Digital Weighing Indicator SI Series Serial in TOP 

Design Studio.  
 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Equipment No. Enter the equipment number of the external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Equipment No. Enter the equipment number of the external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

※ Refer to the manual of the SI model in use to set the Serial I/F as follows. 

 

Step 1. Enter the F-FUNCTION setting mode. 

 

Step 2. Refer to F-FUNCTION LIST to set the items for Serial I/F as follows. 

 

Items Settings Remarks 

Equipment number setting 1  

Serial communication speed 9600 bps  

Serial communication data bit 8 bits  

Serial communication stop bit 1 bit  

Serial communication parity bit None  

Data transmission method setting Command Mode Fixed 

Set “Check Sum” detection in Command Mode. Error detection characters not included in the transmission data Fixed 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

※ Refer to the manual of the SI model in use to make the cable. 

 

■  RS-232C (1 : 1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1   

Serial I/F 

RD 2 TX 

SD 3 RX 

DTR 4  

SG 5 SG 

DSR 6  

RTS 7  

CTS 8  

 9  

 

 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  TxD (+) 

Serial I/F 

 2 TxD (-) 

 3 RxD (+) 

RDB(-) 4 RxD (-) 

SG 5 SG 

SDA(+) 6  

 7  

 8  

SDB(-) 9  

 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  TxD (+) 

Serial I/F 

 2 TxD (-) 

 3 RxD (+) 

RDB(-) 4 RxD (-) 

SG 5 SG 

SDA(+) 6  

 7  

 8  

SDB(-) 9  

 

 

 

☞ Continued on next page. 
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■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 
Signal name  

 

+  TxD (+) 

Serial I/F 

- TxD (-) 

SG RxD (+) 

 

RxD (-) 

SG 

 

 

 

■  RS-422 1 : N connection - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+) 

 

TxD (+) 

 

TxD (+) 

RDB(-) TxD (-) TxD (-) 

SDA(+) RxD (+) RxD (+) 

SDB(-) RxD (-) RxD (-) 

SG SG SG 

 

 

■  RS-485 (1 : N connection) - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+)  TxD (+)  TxD (+) 

RDB(-) TxD (-) TxD (-) 

SDA(+) RxD (+) RxD (+) 

SDB(-) RxD (-) RxD (-) 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

※ Device availability differs according to the SI model. Be sure to refer to ‘Command Mode’ in the SI manual for use. 

 

Device 
Displayed contents 

(or function) 
Bit Address Word Address Read/Write SI command Remarks 

CWT.WEIGHT Current weight value – CWT.WEIGHT 

Read RCWT 

*Note 1) 

CWT.STS Stable status 
CWT.STS0 ~ 

CWT.STS2 
CWT.STS *Note 2) 

CWT.GSNT Total weight/Net weight 
CWT.GSNT0 ~ 

CWT.GSNT1 
CWT.GSNT *Note 3) 

CWT.UNIT Weight unit – CWT.UNIT *Note 4) 

SUB.WEIGHT Subtotal weight value – SUB.WEIGHT 

Read RSUB 

*Note 1) 

SUB.P/N P/N – SUB.P/N  

SUB.COUNT 
Subtotal number of 

weighings 
– SUB.COUNT  

SUB.UNIT Weight unit – SUB.UNIT *Note 4) 

GRD.WEIGHT Total weight value – GRD.WEIGHT 

Read RGRD 

*Note 1) 

GRD.P/N P/N – GRD.P/N  

GRD.COUNT 
Total number of 

weighings 
– GRD.COUNT  

GRD.UNIT Weight unit – GRD.UNIT *Note 4) 

SNO 
Subtotal number of 

weighings 
– SNO Read/Write RSNO/WSNO  

FIN Complete weighing value – FIN Read/Write RFIN/WFIN *Note 5) 

HOUR Hour – HOUR 

Read/Write RTIM/WTIM *Note 6) MIN Min – MIN 

SEC Sec – SEC 

YEAR Year – YEAR 

Read/Write RDAT/WDAT *Note 7) MONTH Month – MONTH 

DAY Day – DAY 

TAR Tare set value – TAR Read RTAR  

SP SP1~4 set value – SP1 ~ SP4 Read/Write RSP1~4/WSP1~4 *Note 5) 

PNO Current part number – PNO Read/Write RPNO/WPNO  

CNO Code set value – CNO Read/Write RCNO/WCNO  

FML 
Weighing formula 

number 
– FML Read/Write RFML/WFML  

BIN Curren BIN number – BIN Read/Write RBIN/WBIN  

DRI Small supply set value – DRI Read/Write RDRI/WDRI  

FRE Drop value – FRE Read/Write RFRE/WFRE  

TTL Cumulative weight value – TTL Read RTTL *Note 5) 

PR 1~2 layer set value – PR1 ~ PR2 Read/Write RPR1~2/WPR1~2  

FIL Set value – FIL Read/Write RFIL/WFIL  

DIGITAL.INPUT External input status 

DIGITAL.INPUT1 

~ 

DIGITAL.INPUT4 

DIGITAL.INPUT Read 

RWRS 

 

RELAY.OUT Relay output status 
RELAY.OUT1 ~ 

RELAY.OUT6 
RELAY.OUT Read  

WZER Zero setting WZER WZER Write WZER  
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Device 
Displayed contents 

(or function) 
Bit Address Word Address Read/Write SI command Remarks 

WTAR Tare ON WTAR WTAR Write WTAR  

WZRS Tare OFF WZRS WZRS Write WZRS  

WHOL Hold ON WHOL WHOL Write WHOL  

WHRS Hold OFF WHRS WHRS Write WHRS  

WPRT Print WPRT WPRT Write WPRT  

WSPR Subtotal print WSPR WSPR Write WSPR  

WGPR Total print WGPR WGPR Write WGPR  

WSTC Subtotal deletion WSTC WSTC Write WSTC  

WGTC Total deletion WGTC WGTC Write WGTC  

WSTR Start operation WSTR WSTR Write WSTR  

WSTP Stop operation WSTP WSTP Write WSTP  

WAUT Print auto WAUT WAUT Write WAUT  

WGRO GROSS/NET KEY WGRO WGRO Write WGRO  

WRUN Start weighing WRUN WRUN Write WRUN  

WSTB Stop weighing WSTB WSTB Write WSTB  

WBRS 
Batch weighing 

initialization 
WBRS WBRS Write WBRS  

WRDY Batch reset WRDY WRDY Write WRDY  
 

*Note 1) Float-type data. 

In order to update data such as STS, GSNT, P/N, COUNT, UNIT, etc. that use the same command, it must be registered with this 

device on the same screen. 
 

*Note 2) 

Response data when the next bit is ON 

STS0 Stable 

STS1 Unstable 

STS2 Overload 
 

*Note 3) 

Response data when the next bit is ON 

GSNT0 Net weight 

GSNT1 Gross weight 
 

*Note 4) It means the unit being displayed by the indicator. Use it as a string only. (Length: 2) 

 

*Note 5) Float-type data 

 

*Note 5) In order to update data of “HOUR” and “SEC” devices, “MIN” devices must be registered together on the same screen. 

 

*Note 6) In order to update data of “YEAR” and “MONTH” devices, “DAY” devices must be registered together on the same screen. 
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※  Write-only Device   Use Method 

① Pop-up the object’s property window → ② Effects and actions → ③ Condition setting → ④ Action setting 

Set to enter data to the corresponding device when a condition occurs in the action setting. 

 

 


