SIEMENS AG.
SIMATIC LOGO! Series

Ethernet Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Supported addresses Page 14

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “SIEMENS AG. — LOGO! Series Ethernet” is as follows:

Communication

Series Module Link I/F System setting
method
PROFINET 3.1 Settings
SIMATIC ) Ethernet ) )
LOGO! LOGQ! 8 (OBA8) Series Interface on — example 1 Twisted pair cable*Note 1)
’ Base Module (Page 4)

*Note 1) Twisted pair cable

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a
direct cable.

B Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

] -

— | Hus '

+ 1:N connection (one TOP and multiple external devices) connection

— m'_: mﬂ: ......... M#F

HUB —

External device connection manual for TOP Design Studio 2/ 14



TOP ooz e
Touch Qperation Panel

2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device [ = |

PLC select [Ethernet]

Filter - [ [al] ~] Search
@ Model () Vendor
Vendor Model
. A
M2I Corporation & 57-300/400 Series
MITSUBISHI Electric Corporation & 57-200 Series
OMRON Industrial Automation
57-1200/1500 Series

LS Industrial Systems ”,

MODBUS Organization

Rockwell Automation

GE Fanuc Automation
PANASONIC Electric Works
YASKAWA Electric Corporation
YOKOGAWA Electric Corparation

Schneider Electric Industries

KDT Systems
RS Automation h
4 Eack | B Next ® Cancel
Select Device H
PLC Setting[ LOGO! Series ]
Alias Name ; |PLC1 BindIP: lAuto v
Interface : |Ethernet ~
Protocol : |OP Communication(COTP) ~ Comm Manual

String Save Mode @ |First LH HL Change

[] use Redundancy

Primary Option

P [192 | [1ss Z] 0 & &
Ethernet Pratocol TCP
Timeout 300 - | msec

Send Wait msec
Base Module 0BAS v

@ Back v oK ® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “SIEMENS AG.
PLC Select the external device to be connected to the TOP.

Interface Protocol

LOGO! Series Ethernet OP Communication(COTP)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [ Project > Project Property TOP Settings] — [ Project Options > "HMI Settings Use” Check > Edit > Ethernet ]
— Set the TOP communication interface in TOP Design Studio.

Project Option

s
-ChangeHMllﬂ] .Add PLC[A) | THITW Change Picicl | [ Delete FLCID)
I'E%m Date / Time Sync.  Screen Option | Unit Convert
e -2ﬁ;_”lz";d”‘é)sem”9 Project Option  Screen Change  HmiSetup = Global Lock & Touch  Project Style  Splash | PLC Buffer Sync.
¥ -?’Divig;it?g)g TS Initialization Edit
5% COMZ (D) Project Setting ~
~15¥ COM3 (0) HMIDisable=0
v g Ethernet (1) Project Name=New project
- PLC1 : MELSEC FX Series Start Mode=Menu
-~ Wireless {0) E::;SUZ::B‘ =L
-8 USBDevice (0) Latch Set=0n~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Contral Panel
P [ﬁ fml Ethernet X
System Devices
~1 - Port
Ethernet Port ¢ ETH1 ~ 0O ]
. 7 ' Link Speed @ Auto -
i :
l MAC Address 00:00:00:00:00:00
PLL Security Date/Time IP Address :|  192.168.0.50
Subnet Mask :  255.255.255.0
Gateway :| 192.168.0.1
: Default Gateway
L] - L3 t,}
Y - -
DNS (1) ]
Ethernet Serial HOK | DNS (2] ¢
- Ethernet
— Frimary IP | 192 168.0.50 -~
= N
— Cable Status
. Ping
Diagnost ic File Fing Bridae Mode : [JUse Bridge
Manager i
Check duplicate | Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR, 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items Description

IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.

Gateway Enter the gateway of the network.
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(2) Communication option setting

M [ Project > Project Property > PLC Settings > ETHERNET(1) > “PLC1 : LOGO! Series"]

— Set the options of the LOGO! Series Ethernet communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)

~ ] TOFP Setting

| L[ 5Y5:RD1520%
Option Module Setting
B FieldBus (0)

LOGO! Series

4§ USBDevice (0)

PLC Setting[ LOGO! Series ]

Alizs Name : [PLC1 | BndP:[aute

Interface : |Ethernet ~

Protocol : |OP Communication(COTP)
String Save Mode : (First LH HL Change

[] use Redundancy

AND
nal) -
0 -
Conditior Edi
Primary Option

P [92 & [68 Z| [0 Z| [ F]
Ethernet Protocol TCP
Timeout 300 & msec
Send Wait msec
Base Module OBAS “

Comm Manual

Apply Close

* The above settings are examples recommended by the company.
Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
IP Enter the IP address of the external device.

Ethernet Protocol

Selects an Ethernet protocol TCP between the TOP and an external device.

Fixed

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external
device and sending the next command request.

Base Module

Select the series of the external device.
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3.2. Communication setting in TOP

* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
B [ Main screen > Control Panel > Ethernet ]

Fo Ethernet
@ Svstem rPort . Dption
Run Ethernet Port : ETHI ~/[0 |+
n ! Link Speed :| Auto M j@
‘ I MAC Address : 00:15:1D:05:38:C5
PLE 5 IP Address :[  192.168.0.50 Sound
e Subnet Mask :|  255.255.255.0
Viewer 2 Gateway :| 192 .168.0.1 —
e [ “ [ Default Gateway .
] ﬁ Ethernet OMS (1) ;|
| .
sama | DNS (2) ¢ ,
Screen m T -Fthernet m
shot h i
B Primary P [ 192.168.0.50 .l
Diagrost ic MRAM
Cable Status :  ETH! Connected | |*malvsis
Bridge Mode : Olse Bridoe | B
[System] lCheck dup | icate] l App |y I Cancel| ] Close r
—]

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting
M [ Main screen > Control Panel > PLC ]

e

TO,

o il PILC
@ System| Driver(ETH) | PLCT(LOGD! Series) |« |
R —
un Interface | Ethernet [~]
!hll Protocol | OP Commun i cat ion{CC|~|
‘ PLE Bind IP L Auto -]
e IP [192 5] 18815 [0 [ (51 |5
Sl m | Ethernet [ TCP_|+]
Fm=u Timeout 300 [ meec
'] Et hernet
[ ﬁ send Wait 0 |3 msec
AmmE
. m | Base Mod. 0BAR |+
shot
Diagnost ic
[System] l Diagnostic HDing Testl

ERI2 e B X
Touch Qperation Panel

”
| Aeply || Cancel |

* The above settings are examples recommended by the company.

=

Items Settings Remarks
Interface Select “Ethernet”. Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Selects an Ethernet protocol TCP between the TOP and an external device. Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external

device and sending the next command request.
Base Module Select the series of the external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [ Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) .
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set as below using "LOGO Soft Comfort V8.0".
For more detailed setting method than that described in this example, refer to the PLC user manual.

A Do not use duplicate IP addresses over the same network.

Hl Connection Settings (Set in Diagram Mode)

Step 1. Tools > Click Ethernet Connections and run “Configure Ethernet Connections”.

B LOGOIsoft Comfort = | B |-

File Edit Format View Tools Window Help
F B & Transfer v OB ke

| Diagram Mode || 4y Determine LOGO! F2

Select Hardware... Ctrl+H
Diagrams -l T L 1wl 2 [
\: i - Compare... Ctrl+Minus ‘-I - e T AN 0o @ Ojm m Q Q 7 &
B Add New Diagram =
ar™ Circuit Diagram1 | 3% Simulation F3

Simulation Parameters...

Connect Modem...

Disconnect Modem

Bl

Ethernet Connections...

Parameter VM Mapping...

Options...

w | Instructions |l

] Instructions 72 | P

o L Constants b

v--z Digital

Input L

Cursar key L o
LOGOETO Function key (00 000 00D

Shiftregister bit (L
e | O R

iStatus 1Ehighd ([

O OUpUE e

. X Open connector 0 | IR L
£ > < >
0BA8, Standard 1002

Selection

%

Step 2. Right click “Ethernet Connections” — Click “Add server connection” to add server connectionsetting.

File Edit Format View Toolz Window Help

F:hpEE XX

E & &

J
2
Ml
=l

Diagram Mode Network Project F 4 N
- Canfigure Ethernet Connecﬁon! I
+ | Diagrams h i Module Add
= f Ak
Gt LR ' | IP Address | 192.168. 0. 51
B Circuit Diagram1 =
a7 g Subnet Mask: |255.255.255. 0

Default gateway

Ethernnet connections

| --ghy Ethernet Connections

Add client connection

Add server connection

+ | Instructions

7] Instructions Al
~-[7] Constants [
-+ [ Digital

L Input

- € Cursor key

~F LOGO! TD Function key

-3 Shift register bit

-lo Status 0 {low)

~hi Status 1 (high) [
~@ Qutput B
% (Jpen connectar Wl T e

[ 0K H Cancel H Help ]

Selection E 0B A8, Standard 1003

External device connection manual for TOP Design Studio

9/ 14



TDP BRI HE B X
Touch Qperation Panel

File Edit Format View Tools Window Help
GBI XXEE O BE|(EE ("

|| Diagram Mode | Network Project

e —

ggdd I\.lte[\;.f Dlagre;m IP Address 192.168. 0.51
ircuit Diagram

Subnet Mask: | 255.255.255. 0
Default g; Yoo .

Ethernnet connections

v | Instructions

] Instructions [
~-["] Constants I:
-+ [ Digital

! Input
© Cursor key

-

LOGO! TD Function key
Shift register bit

Status 0 (low)

i Status 1 Chigh)

9 Qutput

. % Open connector [l © o T il
[<] B
Selection | 0848 Standard 100% | |

W

Step 3. Double click “Connection1” then set in pop-up window as shown below.
@ Check accept all connection requests

@ TSAP : 10.00

File Edit Format View Tools Window Help

G:Rp | XXER O BE|DE|~

I Diagram Mode

Local Properties {Server)

=m0 re—

Connectwith an Operator Panel (QP)

I Accept all connection requests I ......

Only this connection: . . . .

Remote Properties (Client)

[rs o0 |

Keep Alive
Enable the Keep Alive function for this connection

Keep Alive Interval: |I| Seconds

SN

hi Status 1 (high)
O Qutput

% Open connectar [l o [w]

- [<]] |
Selection | 0B48 Standard[ 1002 | |

Step 4. Run Tool > Transfer > PC — LOGO! then after downloading setting information, RUN.
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H Connection Settings (Set in Network Project)

Step 1. Run "Go Online" to locate the module connected to the network, and then "Upload".

File Edit Format Wiew Tools Window Help

s HE ([ XXBRE D BB EE| v
| Disgram Wode | Network Projct

----- L Add New Device

v | Network Project K Add Mew Device | 8 Go Online| &¥ Go Offline | @, Zoom In €, Zoom Out
ﬁ Project [a]

Unkniowen_1
192.168.0.51

(=== =e =]
@ EEEEEEEN

iml
1

+ | Instructic

X il il <

Cut CirkX
Copy Ctri+C
Paste CirlV
Delete Delete
Rename: F2

Add client connection...

Add server connection...

Import...
Export._

Upload. ..

Download...

VO Status...

Properties...

Step 2. Right click module — click “Add server connection”to add server connection setting.

File Edit Format View Tools Window Help

G HE | XX E

EBOC BE(EE |~

I Diagram Mode Network Project

v | Network Project K Add Mew Device | § Go Online| ¥ Go Offline | @, Zoom In €}, Zoomn Out

ﬁ Project

----- I Add New Device

= ~

Unknown_1 [LOGO! 0BA8] -~
Unknowwn_1 |:
192.163.0.51
81 Unknown_1 2
 EEEEEEER
M cut Cirl+X
B copy Ctri+C
B Paste CtrisV
¥ Delete Delete
v||,|151m' Rename F2 | EE
DlnStruc“ Add client connection... dito =
~ [ Con -
B 7 Add server connection... “A | F=I II .....
Import... |EE
Export... known_1 %
Upload.. [A]
Download... S AR —
VO Status... A
Properties... N

I R | B
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Step 3. Set in pop-up window as shown below.
@ Check accept all connection requests
@ TSAP : 10.00

Connection

Device name: |Unknowr'|_1

ERI2 e B X
Touch Qperation Panel

TO, (]

[¥] Accept all connection requests I

IP Address | 192.168. 0.51 | IP Address | . . . |
i TSAP: [rsep: 1000 |
Caonnect with an Operator Panel (OP) @ Client Server
Client @ Semer
Data transfer Add data transfer information (i)
o] Address Length (Bytes) Direction Address Length (Bytes)
1 B =] [ |

Step 4. Run Tool > Transfer > PC — LOGO! then after downloading setting information, RUN.

H IP Settings

Step 1. Tools > Transfer > Click Access control.

-
LOGOISoft Comfort

File Edit Format View Tools Window Help

LA N K & ey

Grs[¥% = = EI Transfer >p
Diagram Mode |_ “i Determine LOGO! F2

Select Hardware... Ctri+H
T - Compare... Ctrl+Minus
| B Add New Diagram
|| &1™ Circuit Diagram1 | 9% Simulation F3
I Simulation Parameters...

PC -= LOGO!

LOGO! = PC

Start LOGO!

Stop LOGO!

Synchronize clock with EM

Show FW version

Clear User Program and Password

Upload Data Log...

Cir+D
Ctri+U

EED 00D Qe | 2

i
i “ Connect Modem...
Confi Net k Add

| “ Disconnect Modem pnigure fetwer ress
N Configure Master/Slave Mode...
i EE,, Ethernet Connections... Set Clock...
I Parameter VI Mapping... Summer time/\Winter time. ..
I_|.7

+ | Instructions —,
i : Options... Set LOGO! TD Power-on Screen...
|| ] Instructions —_ Access control
(| =[] Constants O
M ~-[] Digital Hours counter...
| Input IO Status...

Cursor key Diagnostic...
i LOGO! TD Function key Dynamic server IP fiters...
Shiftregisterbit ——f o e
Status 0 (low) | D S S DI
<] Bl =]
PC --> LOGO! T B 08e Standard100% | ||
—
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Step 2. After updating Accessible LOGO! list, select LOGO! module to connect to.

S . 0 O
EE Interface [
Interface
Connectthrough:| Ethernet +| | Realtek PCle GBE Family Controller -
Target

Target IP address: | 192168, 0.100 Address book

Accessible LOGOL I |

[ 5
Mame IP Address Subnet Mask Gateway MAC address Status
182, 168,0,100 2R, 255, 255,0 0,000 E0-DiC-A0-03-40-F5 Yas
[ Ok ][ Cancel ][ Help ]

TO,
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Step 3. In Online settings > Assign IP Address > New IP settings column, enter new setting module IP address, then

Click "Assign IP address".

Offline settings | Online settings

Current IP address

Operating mode
Clear program anc
TD power-on scret

Default gateway

Hours Counter New IP settings

URRETITERE IP Address:|192.168. 0. 51
PRa ST Subnet Mask |255.255.255. 0
Summer/Winter tin uanetias —
Access control set Default gateway

Dynamic server IP Assign IP address |

Clock Sync with E&

[ 0K ][ Cancel ][ Help ]

- ;
E& L0GO! settings =

Step 4. Reset power to the LOGO! module.
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5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Hl LOGO! 8 (0BAS)

Device Bit Address Word Address Remarks
Digital Input 1001 ~ 1064 1001 ~ 1049
Analog Input Al001.00 ~ AI016.15 AlO0T ~ AlIO16
Digital Output Q001 ~ Q064 Q001 ~ Q064
Analog Output AQ001.00 ~ AQ016.15 AQO001 ~ AQO16
Digital Flag MO001 ~ M064 M001 ~ M049
Analog Flag AMO001.00 ~ AM064.15 AMO001 ~ AM064
Network Input NI001 ~ NI128 NIOOT ~ NI113
Network Analog Input NAI001.00 ~ NAI064.15 NAIOO1 ~ NAIO64
Network Output NQOO1 ~ NQ128 NQOO1 ~ NQ113
Network Analog Output NAQO001.00 ~ NAQ032.15 NAQOO1 ~ NAQO32
Variable Memory V00000.00 ~ V01023.7 VWO00000 ~ VW01022
LOGO! 8 (0BA8) VM Mapping Address
Device VM Address Range
Digital Input 1024 ~ 1031 8 Bytes
Analog Input 1032 ~ 1063 32 Bytes
Digital Output 1064 ~ 1071 8 Bytes
Analog Output 1072 ~ 1103 32 Bytes
Digital Flag 1104 ~ 1117 14 Bytes
Analog Flag 1118 ~ 1245 128 Bytes
Network Input 1246 ~ 1261 16 Bytes
Network Analog Input 1262 ~ 1389 128 Bytes
Network Output 1390 ~ 1405 16 Bytes
Network Analog Output 1406 ~ 1469 64 Bytes
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