LS Industrial Systems
MASTER-K 500H/1000H Series
LOADER Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. Cable table Page 9

Describes the cable specifications required for connection.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems — MASTER K Series 500H, 1000H" is as follows:

Link I/F Communication method System setting

K500H K5P-15H 3. TOP communication
Port on CPU unit \ote 1) RS-232C setting 5. Cable table
K1000H K7P-30H 4. External device setting

*Note 1) PC connection loader port

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k[].]

] TR~
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [COM1]

Fiter : [[al] ~] search:[ ]
@ Model (O Vendor
Vendor Model
Ll
M2l Corporation & XGI/XGR/XEC Series

MITSUBISHI Electric Corporation

& XGK/XEM/XBC Series

& GLOFA-GM Series
LS Industrial Systems
@ MASTER +(805/1205,/20053005/10005) Series

MODBUS Organization
& STARVERT Series

XCODE RFID HF Reader Series [H-1306/1307

3
" MASTER-K(500H/1000H) Series
& MASTER 108, 1051 Series

OMRON Industrial Automation

SIEMEMS AG.

Rockwell Automation

GE Fanuc Automation
PANASONIC Electric Works
‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
Schneider Electric Industries

KDT Systems

RS Automatinn

[ ‘ Back | . Next ® Cancel

Select Device n

PLC Setting[ MASTER-K({500H/ 1000H) Series ]

Alias Name : PLC1

Interface : | CPU Direct ~

Protocol : | MASTER-K(500H,/1000H) 5 v
String Save Mode : |First LH HL Change

[J use Redundancy

Comm Manual

Primary Option

Timeout 300 &1 | msec

Send Wait msec

4 Back + OK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.

External device

Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems”.
PLC Select an external device to connect to TOP.

Interface Protocol
MASTER- Loader MASTER-
K(500H/1000H)Series K(500H/1000H)Series

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

TO,

ERI2 e B X
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

B cvance i
——

[ LA T Change PLCIC]

IV -} TOP Setting I
H 20X

~ -l Option Module Setting
W FieldBus (0)
-4 RFID (0)
w g Device Setting
v g COM1 (1)
-4 PLC1 : MASTERK({500H/100C
- T COM2 (0)
-1 COM3 (0)
W Ethernet (0)
¥ Wireless (0)
-l USBDevice (0)

Date / Time Sync.
Project Option  Screen Change

Use HMI Setup

Hmi >etup Option

Screen Option

[ Delete PLCDI

Unit Convert

HmiSetup  Global Lock & Touch

Project Style  Splash

Initialization I Edit I

PLC Buffer Sync.

X

Start Mode=Menu

Start Sareen No.=1

Latch Use=0

Latch Set=0~0

Communication Error Message =0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplayLockIcon=0

-

Control Panel

'@ System Devices | I Service | @ Ootion
= !
e Serjal =
— -~
T (& .
Serial Port: | COM1 w2
PLC Security Oat e/Time Signal Level
(®) PS-232C () AS-422(4) () RS-485(2)
. Baud Rate: QG500 <
(1] a B — .
M O o LJ Data Bit: 8 -
Ethernet Serial HOH I stop Bit: 1 v
Parity Bit: MNone 7
— Flow: [ff
l ® Png  — AutoSearch  Loopback Test
Diagnost ic HaFnlalgEer Ping K Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C )
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [ Project > Project Property > Device Setting > COM > “PLC1 : MASTER-K (500H/1000H) Series"]
— Set the options of MASTER-K Series CPU Direct communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

v -3 TOP Setting
i [ 5Y5:RD1520%

- FieldBus (0)
- RFID (0)
W i Device Setting

€oM3 (0)
Ethernet (0)
@ Wireless (0)
L. USBDevice (0)

v -F. ]
LC1: MASTER-K(500H/100
U

Option Module Setting Alias Mame

String Save Mode

Primary Option
Timeout
Send Wait

Retry

Protocol :
: |First LH HL Change

[] use Redundancy

- Change HMIH) | | Add PLC [4) TTe) ChangePLCicl | [ Delete PLCID)

PLC Setting[ MASTER-K(500H/1000H) Series ]

:|PLC1

Interface :

CPU Direct ~

MASTER HK(500H/1000H) 5 ~

Comm Manual

Apply Close
Items Settings Remarks
Interface Select “Loader”. Refer to “2. External
Protocol Select "MASTER-K (500H/1000H) Series". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

(i

Oa

Conikrol

Panel

Serial

Serial Port: lCUhﬂ "

Siagnal Level
i RS-232C () RS-422(4) ) BS-485(2)

Baud Rate: | 4600 -
Data Bit: |8

l
|
l
)
l
|
l

|

|
Stop Bit: | 1 ~

|

|

[ ]
] ﬁ Ethernet Serial
] . arc -
- Parity Bit: | Mone
Screen % Flow: l 0f f h
shot ! ‘
Disgrost ic File lAuto Searchl [Loopback Testl
Manager
/
[ App |y H Cancel l —
[System] Close r
Items TOP External device Remarks
Signal Level (port) RS-232C )
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

ERI2 e B X
Touch Qperation Panel

o i PLC
@ svstel poioercooMn) [ PLCT(MASTER-K(500H/ 1000H) Series)
Interface [ CPU Direct Rd
I Protocol | MASTER—K{500H/1000F |+ |
e Timeout 300 |3 msec
send Wait 0 3 msec
min) | Retrv 55
Et hernet
Diagnost ic
[System] Diaanostic

Items Settings Remarks
Interface Select “Loader”. Refer to "2. External
Protocol Select "MASTER-K (500H/1000H) Series". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. Cable table

TO,

ERI2 e B X
Touch Qperation Panel

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

W RS-232C (1:1 connection)

COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name number number | name | arrangement*Note 1)
@) 1 1 cDh
1 5 1 5
© T e e e ;
o) [e) SD 3 3 SD O O
6 9 DTR 4 4 DTR 6 9
Based on G 5 5 G Based on
communication cable DSR 6 6 DSR communication cable
connector front, RTS - - RTS connector front,
D-SUB 9 Pin male D-SUB 9 Pin male
CTS 8 8 CTS
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 32 bits Remarks
Input / Output Relay PO00 — P63F P00 — P63
Auxiliary Relay M000 - M191F MO0 — M191
Keep Relay K000 — K31F KOO - K31
Special Relay FOOO — F63F FOO — F63 *Note 1) Cannot be written
Timer T0000.00 — T1255.15 T0000 — T1255 L/H
Counter €0000.00 — C1255.15 C0000 — C1255
Step Relay S0000 - S0099

Data Register

D0000.00 - D9999.15

DO000 - D9999

*Note 1) The lower 16BIT data of 32BIT data is saved in the address whose screen has been registered, and the upper 16BIT data is

saved in the address next to the address whose screen has been registered.

Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
. 12345678 5678 1234
(hexadecimal)
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