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LS Industrial Systems Co., Ltd

XGT(XGK-CPU), XGB(XBC-CPU/XBM-CPU) Series

CNET Driver
Support version OS V4.0 and over 

XDesignerPlus 4.0.0.0 and over

CONTENTS
Thank you for using TOP series of M2I corporation.

Please read this manual carefully to know connection methods and 

procedures of “TOP to External device”.

1. System configuration Page 2

A section for showing connectable external devices, serial signal 

types, connection configurations. Refer this section to select the 

right system configuration.

2. Selection of TOP, External device  Page4

A section for selecting a Top model and the external device.

3. Example of system setting Page 5

A section for explaining examples to connect communications of 

TOP to External Device.

Select the correct example in your case according to “1. System 

configuration”

4. Communication setting Page 27

A section for Communication setting.

The setting should be the same with the external device.

5. Cable diagram Page 30

A section for cable to connect to external device.

Select a suitable cable diagram for your system.

6. Usable address Page 35

A section for usable address to communicate with external 

device.
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Series CPU*1) Link I/F Comm. type System setting Cable

XGK

XGK-CPUH

XGK-CPUA

XGK-CPUS

XGK-CPUE

XGK-CPUU

XGL-C22A,  CH1 RS232
4.1 setting ex 1

( 5 Page )

5.1 cable diagram 1

( 30 Page )

XGL-C22A,  CH2 RS232
4.2 setting ex 2

( 7 Page )

5.1 cable diagram 1

( 30 Page )

XGL-C42A,  CH1

RS422
4.3 setting ex 3

( 9 Page )

5.2 cable diagram 2

( 31 Page )

RS485
4.4 setting ex 4

( 11 Page )

5.3 cable diagram 3

( 32 Page )

XGL-C42A,  CH2

RS422
4.5 setting ex 5

( 13 Page )

5.2 cable diagram 2

( 31 Page )

RS485
4.6 setting ex 6

( 15 Page )

5.3 cable diagram 3

( 32 Page )

XGL-CH2A,  CH1 RS232
4.1 setting ex 1

( 5 Page )

5.1 cable diagram 1

( 30 Page )

XGL-CH2A,  CH2

RS422 
4.5 setting ex 5

( 13 Page )

5.2 cable diagram 2

( 31 Page )

RS485
4.6 setting ex 6

( 15 Page )

5.3 cable diagram 3

( 32 Page )

XGB

XBM-D□16S

XBM-D□32S

XBC-D□32H

XBC-D□64H

CPU on Cnet
*2)

, CH1 RS232
4.7 setting ex 7

( 17 Page )

5.4 cable diagram 4

( 33 Page )

CPU on Cnet
*2)

, CH2 RS485 
4.8 setting ex 8

( 19 Page )

5.5 cable diagram 5

( 34 Page )

XBL-C21A, CH2 RS232
4.9 setting ex 9

( 21 Page )

5.1 cable diagram 1

( 30 Page )

XBL-C41A, CH2

RS422 
4.10 setting ex 10

( 23 Page )

5.2 cable diagram 2

( 31 Page )

RS485
4.11 setting ex 11

( 25 Page )

5.3 cable diagram 3

( 32 Page )

Type name Image Detail name

Cnet 

on CPU unit
5 pin terminal port of XBC/XBM/XEC CPU module ( RS-232 1 port + RS-485 1 port )

1. System configuration
System configuration of TOP and “LS Industrial Systems Co., Ltd – XGT(XGK), XGB(XBC/XBM) Series”.

*1) Confirm that version written CPU unit label is 1.1 and over.

*2) Cnet port on CPU unit of XGB Series
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■ Connection configuration

ㆍ1 : 1(TOP 1 unit to External device 1 unit) connection – It is available with RS232C/422/485.

ㆍ1 : N(TOP 1 unit to External device N unit) connection – It is available with RS422/485.
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Setting Items Description

TOP Series

Series OS Version

XTOP / HTOP V4.0

Select a TOP series which is communicated with external device.

Install an OS file v3.1 as diagram below before download a project file you have made.

Name Select a TOP model which is communicated with external device.

External Device Vendor Select vendor of the external device which is communicated with TOP.

Select “LS Industrial Systems Co., Ltd”.

PLC Select a model name of the external device which is communicated with TOP.

Select “XGT(XGK), XGB(XBC/XBM) Series CNET”.

Check whether the external device you want to use is connectable or not

in “1. System configuration”.

2. Selection of TOP, External device
Select a external device which is communicated to the TOP.
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Item TOP External device Note

Serial Signal Level (port/channel) RS-232 (COM2) RS-232 (CH 1) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”

-Station Number : Station number of external device.

-CPU Type : Select CPU type 

-Device Read Type : Select protocol type.

3. Example of system setting

Set Communication interface of TOP and " XGT(XGK-CPU),XGB(XBC-CPU/XBM-CPU)Series CNET Driver".

3.1 Example 1

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card. 

5.  double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Parameter Write].

7.  Reset PLC at [Online] > [Reset] > ][Reset PLC].

Item Contents Note

Connection

setting

CH 1

Comm. Type RS232C fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null Fixed

Station No. 0 User set

RunMode CH 1 XGT server fixed
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Item TOP External device Note

Serial Signal Level (port/channel) RS-232 (COM2) RS-232 (CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”

-Station Number : Station number of external device.

-CPU Type : Select CPU type 

-Device Read Type : Select protocol type.

3.2 Example 2

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS232C fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-422 (4 wire, COM2) RS-422 (4wire, CH 1) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET” 

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.3 Example 3

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 1

Comm. Type RS-422 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 1 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-485 (2 wire, COM2) RS-485 (2 wire, CH 1) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.4 Example 4

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 1

Comm. Type RS-485 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 1 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-422 (4 wire, COM2) RS-422 (4wire, CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.5 Example 5

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK]. 

  

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-422 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-485 (2 wire, COM2) RS-485 (2 wire, CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.6 Example 6

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

  

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-485 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-232 (COM2) RS-232 (CH 1) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.7 Example 7

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 1

Comm. Type RS-232C fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 1 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-485 (2 wire, COM2) RS-485 (2 wire, CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.8 Example 8

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5. Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-485 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-232 (COM2) RS-232 (CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.9 Example 9

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6. Transfer setting contents to CPU at [Online] > [Write].

7. Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-232C fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-422 (4 wire, COM2) RS-422 (4 wire, CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.10 Example 10

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card. 

5.  Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-422 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode  CH 2 XGT server fixation
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Item TOP External device Note

Serial Signal Level (port/channel) RS-485 (2 wire, COM2) RS-485 (2 wire, CH 2) User set

Station number (PLC Address) ─ 0 User set

Serial Baud rate [BPS] 115200 User set

Serial Data bit [Bit] 8 User set

Serial Stop bit [Bit] 1 User set

Serial Parity bit [Bit] NONE User set

Run Mode XGT private server User set

■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.

-Station Number : Station number of external device.

-CPU Type : Select CPU type

-Device Read Type : Select protocol type.

3.11 Example 11

Set your system as below.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1.  Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2.  Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3.  Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4.  Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5. Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].

Item Contents Note

Connection

setting

CH 2

Comm. Type RS-485 fixation

Baud rate 115200 User set

Data bit 8 User set

Stop bit 1 User set

Parity bit NONE User set

Modem Type Null fixation

Station No. 0 User set

RunMode CH 2 XGT server fixation
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■ [ Project >Project Property > Project >TOP Setting > TOP Name ]

Set communication interface of TOP.

-Right window : [HMI Setting > check HMI Setting using > Device manager]

-Right window : [HMI Setting > check HMI Setting using > PLC setting]

■ External device setup

Set the communication driver option “XGT(XGK), XGB(XBC,XBM) Series CNET”.. 

■ Setting communication Interface

Item Description

Serial Signal Level Setup signal level(RS-232C/422/485) of PLC connected with COM2/1 port. (COM1 only 

RS-232C)

Serial Baud Rate Setup [communications Baud rate] of PLC connected with COM2/1 port. 

Serial Data Bit Setup [Data Bit] of PLC connected with COM2/1 port.                                    

Serial Stop Bit Setup [Stop Bit] of PLC connected with COM2/1 port.

Serial Parity Bit Setup [Parity Bit] of PLC connected with COM2/1 port.

Time Out [ x100 mSec ] Setup [Time Out] of PLC connected with COM2/1 port.  (Timeout:: waiting time for answer 

of PLC)

Send Wait [ x10 mSec ] Setup [Send Wait] of PLC connected with COM2/1 port.

(Send Wait: communicate after waiting setting time when touch screen requires 

communications.)

4. Communication setting
Communication setup can be set on XDesignerPlus or TOP Main Menu. The setting should be the same with the external device.

4.1 XDesignerPlus setup

Set [Project >Project property] of XDesignerPlus as below.
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Station Num. in Diag.[0~31] Setup [Station Num.(0~31)] using "4.3 Communication Diagnosis”
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PLC setup

PLC Address : 00 Communication 

Timeout : 1000 [mSec] Interface Settings

Delay time of transmission : 0 [mSec]

TOP COM 2/1 : RS - 232C , 115200 , 8 , 1 , NONE

 TOP COM 2/1 setup   communication test

Details Contents

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s response waiting time from external device at [ 0 – 5000 ] x 1 mSec.

Delay time of transmission [ 

x1 mSec ]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP COM 2/1 TOP’s Interface setup to external device.

Port Settings

* Serial communication COM 1 Port

 + COM-1 Port Communication 

  - Baud rate : 115200 [BPS] Interface Settings

  - Data bit : 8 [BIT]

  - Stop bit : 1 [BIT]

  - Parity bit : NONE [BIT]

  - Signal level : RS – 232C

 + COM-2 Port COM-2 Port

  - Baud rate : 115200 [BPS] Communication 

  - Data bit : 8 [BIT] Interface Settings

  - Stop bit : 1 [BIT]

  - Parity bit : NONE [BIT]

  - Signal level : RS – 232C

Details Contents

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Signal level External device – select serial communication method between TOPs.

4.2 Set TOP Main Menu

- When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP COM 2/1 setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] - Setup driver interface.

Step 1–Reference.

Step 2. [ PLC setup ] >[ TOP COM2/COM1 Setting ] – Setup relevant port’s serial parameter.

Step 2-Reference.
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OK! Communication setting normal

Time Out Error! Abnormal Communication setting.

- Error in the setting situation of Cable and TOP / External device (reference 

: Communication Diagnosis sheet)

Designer Version O.S Version

Details Contents Confirm

System Name of CPU OK NG

configuration Name of confront port that is 

communicating
OK NG

System Connection Method 1:1 1:N N:1 OK NG

Connection 

Cable

Name of Cable
OK NG

PLC setup Setup address OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

Assigned Address Limit OK NG

TOP setup Setup port COM 1 COM 2 OK NG

Name of Driver OK NG

Confront Address Project Property Setup OK NG

When Diagnosing 

Communication
OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

4.3 Communication Diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- Confirms if Port [COM 2 or COM 1] setting that is willing to use in [Communication Settings] matches with the setting of external 

devices.

■ Port Communication Issue Diagnosis

- PLC Setting > TOP [ COM 2 or COM 1 ] click "Communication Diagnosis" button.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that is shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Pin No. Signal Pin Assignment *1

Front View of

D-SUB 9 Pin 

(male, convex)

CD 1 1 CD

Front View of,

D-SUB 9 Pin 

(male, convex)

RD

2 2

RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9

XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Pin No. Signal Pin Assignment *1

Front View of    

D-SUB 15 Pin 

(male, convex)

CD 1 1 CD

Front View of,

D-SUB 9 Pin 

(male, convex)

RD 2 2 RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9

XTOP/ATOP COM 1 port
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Pin No. Signal Pin Assignment *1

5. Cable diagram 
This Chapter introduces cable wiring guidance for communication between TOP and PLC concerned. (The cable diagrams in this 

section may differ from the recommendations of LS Industrial Systems Co., Ltd) 

5.1 Cable Diagram Table 1

■ 1 : 1 Connection

(A) XTOP COM 2port(9pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(B) XTOP COM 2 port(15pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(C) XTOP/ATOP COM 1 port ( 6pin)
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Front View of 

D-SUB 6 Pin 

(male, convex)

1 1 CD

Front View of,

D-SUB 9 Pin 

(male, convex)

RD 2 2 RD

SG 3 3 SD

4 4 DTR

5 5 SG

SD 6 6 DSR

7 RTS

8 CTS

9

*1) Pin assignment of the cable connector is seen on the face of Front View.
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XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of

D-SUB 9 Pin 

(male, convex)

RDA 1 TX+

2 TX–

3 RX+

RDB 4 RX–

SG 5 SG

SDA 6

7

8

SDB

9

XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of    

D-SUB 15 Pin 

(male, convex)

– 1 TX+

(skip) TX–

RX+

– 10 RX–

RDA 11 SG

RDB 12

SDA 13

SDB 14

SG 15

ATOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Signal Pin Assignment

5.2 Cable Diagram Table 2 

■ 1 : 1 connection

(A) XTOP COM 2 port(9pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(B) XTOP COM 2 port(15pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(C) ATOP COM 2 port (Terminal block 5 pin)
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Front View of

Terminal block 5 Pin

RDA TX+

RDB TX–

SDA RX+

SDB RX–

SG SG

TOP Direction of 

cable connection and signal

PLC Direction of 

cable connection and signal

PLC

Signal Signal Signal

RDA

TX+ TX+

RDB TX– TX–

SDA RX+ RX+

SDB RX– RX–

SG SG SG

*1) Pin assignment of the cable connector is seen on the face of Front View.1

■ 1 : N connection – Connect as below refer to 1:1 connection.
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XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of

D-SUB 9 Pin 

(male, convex)

RDA TX+

2 TX–

3 RX+

RDB 4 RX–

SG 5 SG

SDA 6

7

8

SDB 9

XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of    

D-SUB 15 Pin

(male, convex)

– 1 TX+

(skip) TX–

RX+

– 10 RX–

RDA SG

RDB 12

SDA 13

SDB 14

SG 15

ATOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Signal Pin Assignment

Front View of

Terminal block 5 Pin

TX+

RDB TX–

SDA RX+

SDB RX–

SG SG

TOP Direction of PLC Direction of PLC

5.3 Cable Diagram Table 3 

■ 1 : 1 connection

(A) XTOP COM 2 port(9pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(B) XTOP COM 2 port(15pin)

11*1) Pin assignment of the cable connector is seen on the face of Front View.RDARDA

(C) ATOP COM 2 port (Terminal block 5 pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

■ 1 : N / N : 1 connection – Connect as below refer to 1:1 connection.
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Signal cable connection and signal Signal cable connection and signal Signal

TX+ TX+

RDB TX– TX–

SDA RX+ RX+

SDB RX– RX–

SG SG SG
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XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of

D-SUB 9 Pin 

(male, convex)

CD 1 +

RD

2 –

SD 3 SG

DTR 4 TX

SG 5 RX

DSR 6

RTS 7

CTS 8

9

XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of    

D-SUB 15 Pin 

(male, convex)

CD 1 +

RD 2 –

SD 3 SG

DTR 4 TX

SG 5 RX

DSR 6

RTS 7

CTS 8

9

XTOP/ATOP COM 1 port
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of 

D-SUB 6 Pin 

(male, convex)

1 +

RD

2 –

SG 3 SG

4 TX

5 RX

5.4 Cable Diagram Table 4

■ 1 : 1 connection

(A) XTOP COM 2 port(9pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(B) XTOP COM 2 port(15pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(C) XTOP/ATOP COM 1 port( 6pin)
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SD 6

*1) Pin assignment of the cable connector is seen on the face of Front View.11
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XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of

D-SUB 9 Pin 

(male, convex)

RDA +

2 –

3 SG

RDB 4 TX

SG 5 RX

SDA 6

7

8

SDB 9

XTOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Pin No. Signal Pin Assignment

Front View of    

D-SUB 15 Pin 

(male, convex)

– +

(skip) –

SG

– 10 TX

RDA 11 RX

RDB 12

SDA 13

SDB 14

SG 15

ATOP COM2
Cable Wiring

PLC

Pin Assignment *1 Signal Signal Pin Assignment

Front View of

Terminal block 5 Pin

RDA

+

RDB –

SDA SG

SDB TX

SG RX

5.5 Cable Diagram Table 5

■ 1 : 1 connection

(A) XTOP COM 2 port(9pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(B) XTOP COM 2 port(15pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.

(C) ATOP COM 2 port (Terminal block 5 pin)

*1) Pin assignment of the cable connector is seen on the face of Front View.
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TOP Direction of 

cable connection and signal

PLC Direction of 

cable connection and signal

PLC

Signal Signal Signal

RDA
485(+)

485(+)

RDB 485(–) 485(–)

SDA
SG

SG

SDB TX TX

SG RX RX

■ 1 : N / N : 1 connection – Connect as below refer to 1:1 connection.
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Device Bit Address Word Address 32 Bit Property

Input / Output Relay P00000 – P2047F P0000 – P2047

L/H*1)

R/W

Auxiliary Relay M00000 – M2047F M0000 – M2047 R/W

Keep Relay K00000 – K2047F K0000 – K2047 R/W

Link Relay L000000 – L11263F L00000 – L11263 R/W

Special Relay F00000 – F2047F F0000 – F2047 R

Timer (Contact) T0000 – T2047 ––––––––––– R/W

Counter (Contact) C0000 – C2047 ––––––––––– R/W

Timer (Current Value) ––––––––––– T0000 – T2047 R/W

Counter (Current Value) ––––––––––– C0000 – C2047 R/W

Data Register D00000.00 – D65535.15 D00000 – 65535 R/W

Communication Data Register N00000.00 – D65535.15 N00000 – N21503 R/W

File Register R00000.00 – R32767.15 R00000 – R32767 R/W

File Register ZR00000.00 – ZR65535.15 ZR00000 – ZR65535 R/W

Item 32BIT 16BIT

address D00100 D00100 D00101

Input data(Hex) 12345678 5678 1234

6. Available Address
The available address of device are as below.

Device(address) range might be different according to series/type of CPU. TOP Series are capable of supporting maximum address 

range which is available in external Device.

Be careful get out of address range.

R:read / W:write
*1) Low 16BIT of 32BIT data is saved address input by touch program, high 16Bit of 32BIT data is saved next address input by touch 

program.

(Ex) If you input [12345678] of hex 32bit data at address [D00100], it will save in 16bit device as below. 

 


