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1. System configuration

TO BRI HE B X
Touch Qperation Panel

The system configuration of TOP and “SHINHAN INDICATOR" is as follows:

System setting

Series ‘ CPU ’ Link I/F Communication method

3. TOP communication

RS-232C setting
SHINHAN INDICATOR RS-232C 1/O Port ) 5. Cable table
RS422,485 4. External device -
setting
B Connection configuration
+ 1:1 connection (one MASTER and one TOP) connection
Master
[
* 1:N connection (one MASTER and multiple TOPs) connection
| [ ] -
T
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n
PLC select [COM2]
Filter : |[.q||] V‘ Search :

(CiModel (@) Vendor
Vendor Model

r

[ ‘ Back | . Next ® Cancel

Select Device n

PLC Setting[ Loadcell Indicator SH Series ]

Alias Name : PLC1

Interface : | Computer Link ~

Protocol : | 5H Indicator Link ~ Comm Marnual
String Save Mode : |First LH HL Change

[J use Redundancy

Primary Option
Timeout 300 &|| msec
Send Wait

Station Mum

@ Back « oK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “Indicator Series”.
PLC Select an external device to connect to TOP.

Interface Protocol

SHINHAN INDICATOR Computer Link SH Indicator Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Praject Option
-(hange HMI[H]

t - TOP Setting !

-l Option Module Setting

[ Delete PCID)

“ Add PLC [4] 1n Change PLC[C]

PLC Buffer Sync. Date [ Time Sync.

Project Option Screen Change | HmiSetup

Screen Option

Unit Convert

Global Lock & Touch Project Style | Splash

Initialization

| Edit |
~

-3 FieldBus (0)
L. RFID (0) Use HMI Setup
v -4 Device Setting =
e U
758 CoM2 (1) Project Setting
H - PLC1: Loadcell Indicator SH Series HMIDisable =0
L-1g® COM3 (D) Project Name =New project

Ethernet (0) Start Mode=Menu

Wireless (0)

[ Start Screen No.=1
.48 USBDevice (0)

Latch Use=0

Latch Set=0~0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

Control Panel

System mDevices PService =\ Option

o Serial
s '
i - Serial Port: (COMZ @
PLC Secur ity Dat &/ Time Signal Level
(®) RS-232C O RS-422(4) O Rs-485(2)
Baud Rate: 38400 o
.- 2| B—
L Data Bit: 8 .
Et herrnet Serial HOK | Stop Bit: i -
Parity Bit: HNone =
I L : % Flow: (ff
L_ A . Ping
: : — ! Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
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M [ Project > Project Property > Device Setting > COM > "PLCT : SHINHAN SH" ]

Set the options of the communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

TOP Setting
-[J 5Y5 : RD1520%

PLC Setting[ Loadcell Indicator SH Series ]

Option Module Setting Alizs Name : [PLC1

-4 FieldBus (0)

- RFID (0)
Device Setting

Interface : | Computer Link

Protocol : | SH Indicator Link

e

L2

String Save Mode : (First LH HL Change

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

[ use Redundancy

Primary Option

Timeout 200 &1 | msec
Send Wait msec
Station Mum
Mode

Stream Mode -~

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Retry Retry attempt
Station Num Prefix
MODE MASTER,STREAM

MASTER = send upon data request

STREAM = continuous communication
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Bun

-

Conitrol Panel

Serial Port:

Signal Level

Serial

| com2

‘ ® RS-2320 O RS-422(4) O RS-485(2) ]
O : :
T Baud Rate: 38400 -
YHC iy
: Data Bit: |8 -
Yiewer f
o o
S L T B ] ISV B
] Ethernet Serial . .
5 ﬁ Parity Bit l None “]
T —
) I!HHI A Flow: | 07 -]
Creen —
hot
e g { lAuto Searchl [Loopback Test]
Diagnost ic h'IaFnialgEer
[ Apply H Cancel ] -
[System] Close r
|
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit none

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

0 :
@ Sys{ Driver(CON2) | PLCI(Loadeel | Indicator SH Series) |v|
Aun Interface | Computer Link R
!Illl Protocol | SH Indicator Link |+]
‘ PLC Timeout 300 2 msec
vHE Send Wait msec
Yiewver [IJ-I‘I] Retry E
— T T
] Et hernet
§O° oce (S i
LB NN
Screen m
shot
Diagnost ic
[Syste [ Diagnostic [ Aep |y HCanceI ]r

el
Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Retry Retry attempt
Station Num Prefix
MASTER,STREAM

MASTER = send upon data request

STREAM = continuous communication
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Configure the communication setting of the external device by referring to its user manual.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of SHINHAN INDICATOR)

W RS-232C (1:1 connection)

coM External device
Pin Signal Pin Cable connection i Pin
arrangement*Note 1) name number Signal name arrangement*Note 1)
1 5 CD 1 1 5
g S SD 3 RD(16) g g
Based on DTR 4 Based on
communication SG 5 communication
cable connector DSR 6 cable connector
front, RTS 7 SG(7) front,
D-SUB 9 Pin male cTs 8 D-SUB 9 Pin male
(male, convex) 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-485 (1:1 connection)

coOM PLC
Pin Signal Pin Cable connection :
Signal name
arrangementNote 1) | hame number
1 5 RDA(+) 1 SDA(+)(15)
g 8 3 RDA(+)(17)
Based on RDB(-) 4 RDB(-)(18)
communication SG 5 SG
cable connector SDA(+) 6
front, 7
D-SUB 9 Pin male 8
(male, convex) SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B RS-422 (1:N connection) - Refer to 1:1 connection to connect in the following way.

TOP
Signal name
RDA(+)

Cable connection and signal direction

PLC

Signal name

RDB(-)

SDA(+)

SDB(-)

SG

Cable connection and signal

direction

PLC

Signal name

SDA(+)

SDB(-

N

(
RDA(+)

RDB(-)

W RS-485 (1:N/N:1 connection) — Refer to 1:1 connection to connect in the following way.

TOP

Signal name

Cable connection and signal direction

PLC

Signal name

RDA(+)

SDA(+)

Cable connection and signal

direction

SG

PLC

Signal name

RDB(-)

SDA(+) ¢

SDB(-)

SDB(-)

(
RDA(+)

i}

RDB(-)

SG

SG

SDA(+)

SDB(-)

(
RDA(+)

RDB(-)
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TOR =32 I
6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 32 bits Remarks

Weight D0.00-D0.31 DO-DO L/H
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