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M2I Corporation 
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CONTENTS 

We want to thank our customers who use the Touch Operation Panel. 

1. System configuration Page 2  

 Describes connectable devices and network configurations. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4  

 Describes how to set the TOP communication. 

4. External device setting Page 10  

 Describes how to set up communication for external devices. 

5. Cable table Page 11 

 Describe the cable specifications required for connection. 

6. Supported addresses Page 13  

 
Refer to this section to check the data addresses which can 

communicate with an external device. 

Appendix. M2I Protocol Page 15 

 Describes the M2I protocol. 
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1. System configuration 

The system configuration of TOP and external devices is as follows: 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

All devices supporting TOP Slave Serial port 

RS–232C 

RS-422 (4wire) 

RS-485 (2wire) 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

 

■ Connectable configuration 

ㆍ1:1 connection 
 

                        

 

 

ㆍ1:N connection 
 

                              ∙∙∙       
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Select the TOP model. 

External device Vendor Select the vendor of the external device to be connected to the TOP. 

Select “M2I Corporation”. 
PLC Select the external device to be connected to the TOP. 

 

Model Interface Protocol 

TOP Master Serial M2I Protocol 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.) 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project] → [Project Property] → [PLC Setting > COM1 > PLC1: TOP Master] 

– Set the options of the communication driver option in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

String Save Mode Set the byte order of data when entering the string data.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry 
Set the number of request retries when the data request result is no 

response/negative response. 
 

Station No. Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial] 
 

 

Items TOP External device Remarks 

Signal Level RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports 

only RS-485.) 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

String Save Mode Set the byte order of data when entering the string data.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry 
Set the number of request retries when the data request result is no 

response/negative response. 
 

Station No. Enter the prefix of an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Serial] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 
 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Cable OK NG 

TOP Version OK NG 

2. External device selection 

3. Communication setting 

Communication port OK NG 

Communication driver and protocol OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication diagnostics OK NG 

Serial 

Parameter 

Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External 

device 

CPU OK NG 

 

Communication port OK NG 

Protocol OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial 

Parameter 

Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP. 
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5. Cable table 

 

■ RS-232C (1:1 connection) 

COM1 / COM2 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 
Signal name Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

    

 

RD 2 RD 

SD 3 SD 

   

SG 5 SG 

   

   

   

   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:1 connection) 

COM1 / COM2 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM1 / COM2 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  SDA(+)  

 2 SDB(-) 

 3 RDA(+) 

RDB(-) 4 RDB(-) 

SG 5 SG 

SDA(+) 6  

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 (1:1 connection) 

COM3 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

 

 

+  +  

- - 

SG SG 

  

 

■ RS-422 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+) 

 

SDA(+) 

 

SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 

SG SG SG 

 

■ RS-485 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA(+)  SDA(+)  SDA(+) 

RDB(-) SDB(-) SDB(-) 

SDA(+) RDA(+) RDA(+) 

SDB(-) RDB(-) RDB(-) 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows: 
 

Address Bit Word 

D D0000.00 ~ D9999.15 D0000 ~ D9999 
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Appendix. M2I Protocol 

 This chapter describes the M2I protocol. 
 

There are two types of M2I protocol commands: READ/WRITE, which use ASCII code. 
 

 Frame Contents Direction 

Read Read request System buffer request to read data. Master  Slave 

Read response Response to read request Master  Slave 

Write Write request Request to write data on system buffer Master  Slave 

Write response Response to write request Master  Slave 
 

1. Read request 
 

 Size (Byte) ASCII HEX Contents 

Start code 1 ENQ 0x05 Start code of requested frame 

Prefix 2 01 (Dec) 0x3031 SLAVE device prefix 

Command 1 R 0x52 Read data command 

Address 4 0100 (Dec) 0x3031, 0x3030 System buffer address of SLAVE device 

Quantity 2 0x10 (Hex) 0x3130 Amount of data 

End code 1 EOT 0x04 Code that denotes the end of a frame 

BCC 2 0xD9 (Hex) 0x4439 The last byte of the summed value from prefix to 

end code 
 

The example in the table above depicts a read request frame of 16 word data from system buffer number 100. 

 

2. Read request 
 

 Size (Byte) ASCII HEX Contents 

Start code 1 ACK 0x06 Start code of response frame 

Prefix 2 01 (Dec) 0x30, 0x31 Device prefix 

Command 1 R 0x52 Read data command 

Data 4 x n 0x1234 (Hex) 

0x5678 (Hex) 

… 

0xFFFF (Hex) 

0x3132, 0x3334 

0x3536, 0x3738 

… 

0x4646, 0x4646 

Data 

End code 1 EOT 0x04 Code that denotes the end of a frame 

BCC 2 0xB7 (Hex) 0x4237 The last byte of the summed value from prefix to 

end code 
 

The example in the table above depicts a response frame of n data from the system buffer address that received the read request. 

 

3. Write request 
 

 Size (Byte) ASCII HEX Contents 

Start code 1 ENQ 0x05 Start code of requested frame 

Prefix 2 01 (Dec) 0x3031 SLAVE device prefix 

Command 1 W 0x57 Data write command 

Address 4 0100 (Dec) 0x3031, 0x3030 System buffer address of SLAVE device 

Quantity 2 0x01 (Hex) 0x3031 Amount of data 

Data 4 x n 0x1234 (Hex) 0x3132, 0x3334 Data 

End code 1 EOT 0x04 Code that denotes the end of a frame 

BCC 2 0xAB (Hex) 0x4439 The last byte of the summed value from prefix to 

end code 
 

The example in the table above depicts a frame that requests writing the data 1234 onto 1 address from system buffer 100. 
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4. Write request 
 

 Size (Byte) ASCII HEX Contents 

Start code 1 ACK 0x06 Start code of response frame 

Prefix 2 01 (Dec) 0x30, 0x31 Device prefix 

Command 1 W 0x57 Data write command 

End code 1 EOT 0x04 Code that denotes the end of a frame 

BCC 2 0xBC (Hex) 0x4243 The last byte of the summed value from prefix to 

end code 

 

5. BCC error response 
 

 Size (Byte) ASCII HEX Contents 

Start code 1 NAK 0x15 Start code of negative response frame 

Prefix 2 01 (Dec) 0x30, 0x31 Device prefix 

Command 1 2 0x32 BCC error 

End code 1 EOT 0x04 Code that denotes the end of a frame 

BCC 2 0xAC (Hex) 0x4143 The last byte of the summed value from prefix to 

end code 

 


