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LS Industrial Systems 

 MASTER-K Series  

CPU Direct Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “LS Industrial Systems – MASTER-K Series CPU Direct” is as follows: 

 

Series CPU Link I/F Communication method System setting Cable 

K1000S K7P-30AS 

Port on CPU unit*Note 1)
 RS-232C 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

K300S K4P-15AS 

K200S 

K3P-07AS  

K3P-07BS  

K3P-07CS 

K120S 

K7M-D□20U  

K7M-D□30U  

K7M-D□40U  

K7M-D□60U 

K80S 

K7M-D□10S  

K7M-D□20S  

K7M-D□30S  

K7M-D□40S  

K7M-D□60S 

K10S K14□-D□□ 

K30S K14P-D□□ 

K60S K56P-DRS 

K100S K2P-02S 

K2PC-02S 

K10S1 K14P1-DRS 

K500H K5P-15H 

K1000H K7P-30H 

*Note 1) PC connection loader port 

 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “LS Industrial Systems”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

MASTER-K Series CPU Direct CPU 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-232C 

(CPU port) 
Fixed 

Baud Rate 38400 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None. Fixed 

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “PLC1 : MASTER-K Series”] 

– Set the options of MASTER-K Series CPU Direct communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “CPU Direct”. Refer to “2. External 

device selection”. Protocol Select “CPU”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-232C 

(CPU port) 
Fixed 

Baud Rate 38400 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None. Fixed 

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

Items Settings Remarks 

Interface Select “CPU Direct”. Refer to “2. External 

device selection”. Protocol Select “CPU”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

■ The CPU direct port communication interface for “MASTER-K Series” “K80S, K120S, K200S, K300S, K1000S” is fixed to the below 

configuration value, therefore configure the TOP interface as follows. 
 

 
 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-232C 

(CPU port) 
Fixed 

Baud Rate 38400 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None. Fixed 

 

 

■ The CPU direct port communication interface for “MASTER-K Series” “K10S, K10S1, K30S, K60S, K100S, K500H, K1000H” is fixed to 

the below configuration value, therefore configure the TOP interface as follows. 
 

 
 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C 

RS-232C 

(CPU port) 
Fixed 

Baud Rate 9600 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit None. Fixed 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.”) 
 

■ RS-232C (K80S, K120S, K200S, K300S, K1000S, K500H, K1000H) (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C (K10S, K30S, K60S, K100S) (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1  

 

Based on 

communication 

cable connector 

front, 

D-SUB 6 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4  

SG 5 5 SG 

DSR 6 6  

RTS 7  

CTS 8 

 
9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C (K10S1) (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 RD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 6 Pin male 

(male, convex) 

RD 2 2  

SD 3 3  

DTR 4 4 SD 

SG 5 5  

DSR 6 6 SG 

RTS 7  

CTS 8 

 
9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.  
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address Remarks 

Input / Output Relay P000 – P63F P00 – P63  

Auxiliary Relay M000 – M191F M00 – M191  

Keep Relay K000 – K31F K00 – K31  

Link Relay L000 – L63F L00 – L63  

Special Relay F000 – F63F F00 – F63 Cannot be written 

Timer(Contact) T000 – T255 –  

Timer(Elapsed Value)  T000 – T255  

Counter(Contact) C000 – C255   

Counter(Elapsed Value)  C000 – C255  

Step Relay  S00 – S99  

Data Register D0000.00 – D9999.99 D0000 – D9999  

 

*The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved 

in the address next to the address whose screen has been registered. 

   Ex. When saving 32 BIT data hexadecimal data 12345678 in address D00100, it is saved to 16 BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 

 


